Репаки от elchupacabra

Microsoft .NET Framework

Microsoft .NET Framework — программная платформа, выпущенная компанией Microsoft в 2002 году. Основой платформы является исполняющая среда Common Language Runtime (CLR), способная выполнять как обычные программы, так и серверные веб-приложения. .NET Framework поддерживает создание программ, написанных на разных языках программирования. Платформа необходима для установки и корректной работы многих программ, поэтому необходима пользователям.


Ссылки на оригинальные пакеты Microsoft:

.NET Framework 1.1 - практически не используется

.NET Framework 3.5 SP1 - включает в себя версии 2.0 SP2 и 3.0 SP2 (входит в состав Windows 7)

.NET Framework 4.0 - последняя версия с поддержкой Windows XP

.NET Framework 4.8 - для Windows 7 и выше

.NET Framework 4.8.1 - для Windows Windows 10/11


ASP.NET Core 3.1 Runtime 3.1.28                  x86 / x64 - для Windows 7 и выше

.NET Core 3.1 Desktop Runtime 3.1.28         x86 / x64 - для Windows 7 и выше


ASP.NET Core 6.0 Runtime 6.0.8                    x86 / x64 - для Windows 7 и выше

NET 6.0 Desktop Runtime 6.0.8                      x86 / x64 - для Windows 7 и выше



Сборки:

.NET Framework 1.1-4.0 - перепаковка от simplix для WinXP SP3 x86

.NET Framework 4.8 - перепаковка от sov44 для Win7 SP1 (с обновлениями на 17.05.2020)



Утилиты:

.NET Framework Cleanup Tool - для удаления выбранных версий .Net Framework из системы

.NET Framework Repair Tool - для устранения проблем с установкой или обновлением .NET Framework





GIF-инструкции (образцы) по загрузке с сервисов: "Turbobit", "Katfile", "Up-load", "Uploadrar".

Прямые ссылки на загрузку (KrakenFiles / Яндекс Диск) доступны только для группы "Меценат" (Что такое Premium?).



Информация

Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.


Комментариев: 19

    1. liliil
        Постояльцы
       Автор: liliil
      16.09.2022 03:27  
      Я только играю онлайн и смотрю фильмы что из этого надо ставить?
      У меня Win 7 max (X64)
      ASP.NET Core 3.1 Runtime 3.1.28 x86 / x64 - для Windows 7 и выше
      .NET Core 3.1 Desktop Runtime 3.1.28 x86 / x64 - для Windows 7 и выше
      ASP.NET Core 6.0 Runtime 6.0.8 x86 / x64 - для Windows 7 и выше
      NET 6.0 Desktop Runtime 6.0.8 x86 / x64 - для Windows 7 и выше
      NET Framework 4.8 - перепаковка от sov44 Стоит
      1. QZMTCH
          Меценат
         Автор: QZMTCH
        16.09.2022 14:45  
        скорее всего ничего, все что вам нужно уже у вас стоит, или если нужно то вылетит ошибка и напишет что вот этого нет, и скачает само, вообще NET Framework 4.8 для всего сейчас достаточно, его и ставь если еще не стоит, вот этой программой DotNetVersions можно посмотреть что у тебя установлено (просто кликаешь по .exe и в консоли показывает все установленные версии), остальные net5\6 и т.д идут как правило вместе с прогами в папке (у тех кого я видел) поэтому достаточно 4.8
    2. Fames_Magna
        Постояльцы
       Автор: Fames_Magna
      10.09.2022 22:50  
      .NET Framework 4.8.1 - при запуске пишет, моя система более не поддерживается!
      Win7ProSP1x64
    3. liliil
        Постояльцы
       Автор: liliil
      27.08.2022 05:25  
      Вообще не понимаю в этом , подскажите какие библиотеки поставить для игр и программ я не программист...
      ASP.NET Core 3.1 Runtime 3.1.28 ?
      ASP.NET Core 6.0 Runtime 6.0.8 ?
      .NET Framework 4.8 - перепаковка от sov44 ?
      1. LR.Support
          Меценат
         Автор: LR.Support
        27.08.2022 10:02  
        Там на странице есть ссылка на оригинальный пакет .NET Framework 4.8.1. Его точно лучше установить. А вот ASP.NET Core Runtime и .NET Core Desktop Runtime лучше устанавливать по требованию. Хотя вреда точно не будет, да и занимают они немного.
    4. XX-J...
        Постояльцы
       Автор: XX-J...
      25.06.2022 13:21  
      Сборка MS .NET v6.0.6 (Win7+) на основе batch автоустановщика и .msi файлов. Включает все возможные компоненты: Runtime, Desktop Runtime, ASP Shared Framework, ASP Hosting Bundle Options, ASP Module для IIS; для всех возможных архитектур: x86-32, x86-64, ARM64. Присутствует batch автоудаляльщик этой же версии.
    5. karpuha
        Постояльцы
       Автор: karpuha
      15.04.2022 02:07  
      Почему-то умалчивается про русские пакеты для .NET Framework Они входят в раздачу?
      1. QZMTCH
          Меценат
         Автор: QZMTCH
        15.04.2022 03:02  
        что значит русские? это библиотеки кода для программ, они насколько мне известно не имеют локализаций, локализации только в инсталляторе, а сами библиотеки все одинаковые, для всех стран
        1. di0gen
            Постояльцы
           Автор: di0gen
          15.04.2022 08:37  
          На сколько помню, то языковой пакет нужен только для отображения диалоговых сообщений об ошибках и т.д.
    6. XX-J...
        Постояльцы
       Автор: XX-J...
      23.01.2022 00:21  
      Сборки:
      MS .NET Framework vv1-4 - перепаковка от ricktendo, сделанная по такому же принципу как и репак simplix'a. Только репак simplix'a от февраля 2013 г., а ricktendo от февраля 2019 г.

      MS .NET v6.0.1 (Win7+) - мой репак на основе batch автоустановщика и .msi файлов. Включает все компоненты обеих разрядностей: Runtime, Desktop Runtime, ASP Shared Framework, ASP Hosting Bundle Options, ASP Module для IIS. Присутствует batch автоудаляльщик этой версии.

      Утилиты:
      MS .NET Framework vv1.0-4.7.2 Cleanup Tool - версия от мая 2018 г., с поддержкой .NET Framework v4.7.2. Присутствующая здесь - от июня 2014 г., с поддержкой .NET Framework v4.5.2.

      MS .NET Framework vv1.0-4.7.2 Verification Tool - предназначен для автоматического выполнения набора шагов для проверки состояния установки одной или нескольких версий .NET Framework. Он проверит наличие файлов, каталогов, ключей и значений реестра .NET Framework. А также проверит, что простые приложения, использующие .NET Framework, могут исполняться правильно.

      MS .NET Framework vv2.0-4.8 Repair Tool - это Repair Tool v4.6.1528 (для vv2.0 - 4.6.1, XP+) + Repair Tool v4.8.4072 (для vv3.5SP1 - 4.8, Win7+). Здесь предлагается только второй вариант, т.е. v4.8.4072.
    7. qq1102754536
        Постояльцы
       Автор: qq1102754536
      7.11.2021 16:06  
      4.8.4115.0
    8. bipbipyajip
        Постояльцы
       Автор: bipbipyajip
      14.10.2021 01:13  
      привет, Нет фреймворка вообще надо по очереди от 3.5 до 5 установить? или ток последнюю. Если установлю ток последнюю 5, то написанный на 4.5 допустим будет работать?
      1. QZMTCH
          Меценат
         Автор: QZMTCH
        14.10.2021 04:37  
        Привет, net 5 это продолжение .net core 3.1, это отдельные библиотеки для "современных" программ (понятно, что и на .net framework пишут проги), если установишь 4.8 то будут работать программы которые требуют 4.8, если какая то программа требует 3.5, то надо будет и ее установить, а если установишь core 3.1 и 5 будут работать проги которые требуют core, а те кто на framework написаны, работать не будут, потому, что это разные библиотеки, чет я сомневаюсь что не установлен у тебя framework, он в винде (вроде как) по умолчанию идет сразу 4.8 проверь вот программой .NET Version Detector сразу скажу у меня стоит 4.8 и для всего ее достаточно, 3.5 если потребуется какой то программе всегда можно поставить, а core, все кто сейчас пишет программы на этих библиотеках, запихивают их в папку с программой (обычно, если портабл) или отдельно программу без библиотек если у тебя установлена та которая нужна программе, и соответственно практически не нужно ничего устанавливать, ну если хочешь можешь все установить, но повторюсь, отвечая на вопрос, установив net 5, программы требующие framework работать не будут (если у тебя его нет на компе, в чем я сомневаюсь)
      2. elchupacabra
          Администратор
         Автор: elchupacabra
        14.10.2021 09:30  
        4.5 и 5 - это немного разное. Они не взаимозаменяемы. 4.8 ставить, 5 - если софт какой-то требует.
        1. bipbipyajip
            Постояльцы
           Автор: bipbipyajip
          14.10.2021 22:35  
          если я установлю только 4.8 то все написанные приложении на версии 4(4.0 , 4.5.2, 4.7...) будет работать? понял правильно?
          1. elchupacabra
              Администратор
             Автор: elchupacabra
            14.10.2021 23:46  
            Да 4.8 замещает все предыдущие 4.x.
            1. bipbipyajip
                Постояльцы
               Автор: bipbipyajip
              15.10.2021 00:12  
              спасибо за информацию.